gyp: No se detectó ninguna versión de Xcode o CLT macOS

Si ha actualizado recientemente su macOS, es posible que reciba este error mientras realiza una instalación de npm habitual.

gyp: ¡No se detectó ninguna versión de Xcode o CLT!

gyp ERR!
configurar error

La solución general a este problema es instalar XCode. Para instalar la línea de comandos de XCode, debe ejecutar el siguiente comando.

xcode-select –instalar

Cuando ejecuta este comando, es posible que reciba el mensaje de que XCode ya está instalado. Para solucionar este problema, necesitamos reinstalar XCode en nuestro MacOS.

Para reinstalar la línea de comandos de XCode en macOS, ejecute los siguientes comandos paso a paso.

Paso 1: busque la ubicación de instalación de XCode

Para obtener la ruta de instalación de XCode, ejecute el siguiente comando.

xcode-select –print-path

El resultado de este comando será / Library / Developer / CommandLineTools . Si es diferente, tome nota y copie la ruta.

Paso 2: eliminar la instalación de XCode existente

Utilice el siguiente comando para eliminar la instalación de XCode existente.

sudo rm -r -f / Biblioteca / Desarrollador / CommandLineTools

Es posible que reciba este mensaje para reinstalar las herramientas de línea de comandos de XCode.

Haga clic en el botón de instalación y siga el resto de las instrucciones.

Paso 3: Instalar las herramientas de línea de comandos de XCode.

Si no recibe el mensaje para reinstalar las herramientas de línea de comandos de XCode, ejecute el siguiente comando en la terminal.

xcode-select –instalar

Haga clic en el botón de instalación y luego acepte la licencia para continuar con la instalación.

Dependiendo de la velocidad de Internet, el sistema tardará algún tiempo en completar la descarga de las herramientas de desarrollo de la línea de comandos.

Una vez finalizada la instalación. Intente realizar la instalación de npm nuevamente y no recibirá el error de macOS sin versión Xcode o CLT detectada .

Deja una respuesta

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *